Back

Preview loading issues within project editor

May 28, 2026 at 10:04 AM PDT Resolved after 20m

Updates

Resolved

We have identified and deployed a fix for the issues with the preview not loading within project editor and are actively monitoring.

May 28, 2026 at 10:24 AM PDT
Monitoring

We have identified and deployed a fix for the issues with the preview not loading within project editor and are actively monitoring.

May 28, 2026 at 10:20 AM PDT
Identified

We have identified some issues with the preview not loading within project editor and working on a fix.

May 28, 2026 at 10:04 AM PDT