Back

Domain purchasing is down

August 7, 2026 at 11:37 AM PDT Resolved after 1h 39m

Updates

Resolved

The issue is resolved.

August 7, 2026 at 01:17 PM PDT
Identified

Domain purchasing feature is down. We have identified the root cause and is working on a fix.

August 7, 2026 at 11:37 AM PDT